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This QuickStart guide is intended to help the User understand the project file system employed by
KeyWallPRO and how to protect project data.

KeyWallPRO operates differently than many design software programs in that it utilizes its own internal
database system to store project information rather than using conventional Windows Open and Save
dialog boxes and the Windows Explorer to locate and manipulate files on a hard drive.

Saving information to its internal database allows KeyWallPRO to:
» Save and sort projects by Client vs. file name.
» Save revisions within the project file avoiding multiple file creation.

+ Save input data as entered, no need to manually save files or lose data if a crash occurs before
saving a project.

» Retain all project related information in a database so that older files will be recreated exactly as
saved with archived data.

Note: KeyWallPRO saves data as you enter it so there is no ability to exit a project without saving or
trying "what if" scenarios without saving the changes. However, creating a revision will copy the
project information and permit modifications without affecting the original data.

While this method has advantages, it is extremely important to backup data on the computer C: drive
where the program database resides. As an additional safeguard, KeyWallPRO requires that a file
backup path be established for each project so that a project backup file will be saved to an external
drive, network drive, or "cloud" storage site. This backup saving occurs when changing projects or when
closing the program where a dialog box is presented that allows user to save the backup file or not.

Note: The actual project database is saved in the User's AppData folder that is typically hidden in
most Windows file display screens. Backing up the User folder is recommended.

The basic principals of the project file database system are outlined on the following pages.
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The first time KeyWallPRO is started, it is best to setup an external device or location as a place for the
project backup files that will be automatically saved when changing projects or exiting the program. The

I

Setting Up the Default Backup Directory
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default file path set when beginning a project becomes the starting point for saving project specific
backup files. The steps are:

il .

Go to the Settings dropdown menu and select Options.
Select the Project File Location tab.

Click on the File Explorer button to bring up the Windows directory structure box;
Locate an external device, network location, or cloud drive for backup files

(engineering network directory, W:, in this example).

oo

Create a New Folder for saving backup files (2018 Projects in this example).
Click on Select Folder to set as Default.

7. Project backup files will be saved in the format: Project Name_Rev#.vks

[KJ KeywallPRO

File Walls [ Settings| Help

@ Standard Mode

Professional Mode

1) options

Version: 1.38.13.801

Options

Project Root Folder
W:\2018 Projects

V] Autosave Project file

KeyW. FJQR

=3 {E=E X
KeyWall PR@
(2)
Analysis | Reinforcemen t | stabilty Report | Other

Select Folder

@uv\ » Computer » engineering on 'Mac' (W:) » 2018 Projects

Organize v | New folder @

b My Music 4 Name
= My Pictures
B My Videos
% OneDrive
i Saved Games
& Searches
1% Computer

& Floppy Disk Drive (A)
&, Local Disk (C)

<3 DVD Drive (D:)
4 9 engineering on ‘Mac' (W:)
&9 21 iMac TM Backup on 'Mac' ()

a
Folder] 2018 Projects @

@ Select Folder Cancel
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Setting Up New Project

After setting the Default Backup location, creating a New Project is the next logical progression which is
accomplished following these steps:

1. Go to the File dropdown menu and select New Project. This will bring up a terraced sub
menu with two methods of wall design/analysis.

2. Select New Full Wall Design or New Wall Section Analysis.

3. The New Project setup screen will then appear. Enter the Client name and all project related
information (program will not continue without key information).

4. Select a Design Methodology from the pulldown menu.

5.  Set or confirm the Project File Folder Path backup location.

6.  Select the Default Backup Directory Location if desired (press Select Folder) or create a
folder within the Directory for more specific project file saving needs.

7. After the project information and backup path are set, a wall design can be created.
KeyWallPRO operating instructions are in a separate QuickStart guide and Help files.

KeyWallPRO [E=1EsEEX|
Walls ~ Settings  Help
INEWPIOJEE! » New Full Wall Design Ctrl+N I< 6 Wa“ PR&
Open Project ... Ctrl+0 New Wall Section Analysis ~ Ctrl+W y
Save A CtrlsS
Load Project From ... T+l |
New Project From Templatd (17 project : [Rev. 1] - KeyWallPRO = o)
Save Project as Template | 'Fite Walls - Settings Help
PDF Report
Project y
KeyWa
ErmrimE e Client Revisions
Export 5 Number Created Last Modified
Project Name
Import Block Definition 55 21 1/24/18 1/24/18
Bit 3 Project Location
Project Number  Prepared By
[ < Copy ] [ P setas Active [ Delete ]
Revision Notes
Template:  None
(4: |M=thodu|ogy
Measure -
© U.S.mperial s.L
Create Wall @
Project Notes
Version: 1.38.13.801
Project Files @
Folder Path
Version: 1.38.13.801 GE all Systems LLC
rd 5\
K] Select Folder \°/
@\/" | Computer »engineering on Mac' (W) » 2018 Projects | [ 49| Search 2018 Projects
Organize v New folder
1% Computer

& Floppy Disk Drive (A:)

&, Local Disk (C:)

< DVD Drive (D)

# engineering on 'Mac' (W:)

&9 21 iMac TM Backup on ‘Mac' (X)) _ m

Folder: 2018 Projects

©®

Select Folder |
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Open Project...

Opening an existing project is accomplished by following these steps:

1. Go to the File dropdown menu and select Open Project... which will open the Open Project
navigator window.

2. Select Client from the Client pulldown menu.

3. Select a Project from the list presented for selected Client, open file by double-clicking
project line or pressing OK.

4.  Allfile information is retrieved including the backup file path saved.

v{! KeyWallPRO =8 =R ===

Walls _ Settings Help
New Project »

D[ Open Project ... Ctrl+0 Keywa ll PR&

ve As Ctrl+S o
‘ I openProject (2) =
Load Project From ... CulsL
New Project From Template » Ordered by: Name Clent  Client 1 -l /- Biter
Save Proj S Ctrl+T Number & Name Client Project Location Prepared By Modified
— Number A Name A Client 1 Location A Designer A 1/24/18
Ctrl+

Number & Name B Clent 1 @ Tocation B Designer & 12418 \

Import Block Definition File

Exit

K] Project Number A: Name A [Rev. 1] - KeyWalIPRO @ Lol e )

File Walls Settings Help

™k KeyWall PR@

Client
Client 1 -

Revisions

Number Created Last Modified
Project Name
1 1/24/18 1/24/18
iy & 24/ 24/

Project Location
Location A

Version: 1.38.13.801

Project Number  Prepared By -
Number A Designer A [ < Copy ] [ P setas Active [ = Delete ]

Revision Notes
Template:  None

Methodology
[aastTo 2010 tRFD) >

Measure b

© U.S.Imperial s.L

Create Wall
Project Notes

Project Files

Folder Path
W:\2018 Projects

Version: 1.38.13.801 [AASHTO 2010 (LRFD) |

Keystone Retaining Wall Systems LLC
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1. Go to the File dropdown menu and Select Save As... which brings up the Windows directory

structure dialog box.

2. Select a location to Save project file (engineering network directory, W: and folder "2018

Projects" in this example).

3. Use program default name (Client Name_Project Name_Rev Number_Date Stamp.vks) or
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Save As...

rename saved file as needed including .vks suffix.

KeyWallPRO automatically saves project information as entered thus there is no Save option in the
program. However, sometimes it is necessary to save a file to send to another user, create a special
backup file, or send to Keystone for assistance. To manually save project information, follow these steps:

Note: Prior to manually saving, ensure that the wall design and analysis data is not left in an
incomplete state for best results with a saved file (make sure all walls have been generated,

analyzed, etc, before saving).

Project Number A: Name A [Rev. 1] - KeyWallPRO
Walls ~ Settings Help
New Project »
Open Project .. Ctrl+0
1 )| savess.. Ctrl+S
Load Project From ... Ctrl+L

)

New Project From Template »
Save Project as Template Ctrls T
PDF Report ... Ctrl+P
Export to AutoCad ...

Export to GSlope ...

Export to ReSSA ...

Import Block Definition File

Measure
© U.S./Imperial S.L

Project Notes

Project Files

Folder Path
W:\2018 Projects

Version: 1.38.13.801

[AASHTO 2010 (LRFD)

[E=5 E=H 5
Revisions
Number Created Last Modified
w 1/24/18
[ < Copy \ [ AP setas Active ] = Delete
Revision Notes
Riomers \2/ =
@Qv‘ »| Computer » engineering on "Mac' (W:) » 2018 Projects| [ 4 |[ search 2018 )
Organize v New folder )
% OneDrive 4 Name . Date modified Type Size
£ Saved Games o .
|| Name A_RevL.vks 24/18 2:51 PM VKS File

£ Searches
18 Computer
4 Floppy Disk Drive (A)]
&, Local Disk (C) i
&3 DVD Drive (D)

3 shared on 'Mac' (V:)
(2

% 21 iMac TM Backup

File name: Client1_Name A_Revl 201801241123

- < i

Save astype: [KeyWallPRO Files

“ Hide Folders
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Load Project From...

Loading a backup or manually saved project file is accomplished following these steps:

1. Go to the File dropdown menu and select Load Project From... from which brings up the
Windows directory structure dialog box.

2. Select a location where the saved project file resides (engineering network directory, W: and
folder "2018 Projects” in this example).

3. Select any file with .vks suffix and open file by double-clicking the selected project line or

pressing Open.

4. If the selected file is already in the User's database, a dialog box will appear that offers the
choice of Loading as a New Project or Load as New Revision to an existing file.
Note: a new project created this way will have the same name as an existing file so the project
should be renamed immediately to avoid duplicate file names.

{K] Project Number A: Name A [Rev. 1] - KeyWallPRO =5 =R =]
Walls ~ Settings  Help
e : KeyWall PR
Open Project ... Ctrl+0 ey a
Save As .. Ctrl+S Revisions
(1 || Load Project From ... CHEE Number Created Last Modified
New Project From Template v 124/18 124/18
Save Project as Template CtrlsT
PDF Report ... Ctrl+P
Export to AutoCad ...
Export to GSlope .. [ < Copy ] [ P setas Active = Delete
Export to ReSSA ... Revision Notes
Import Block Definition File {K] Open =
Exit @Qv‘ >| Computer » engineering on ‘Mac' (W:) » 2018 Projects| > ‘ 43 ||[ Search 2018 Projects o]
Organize v New folder >~ 0 @
Measure B Saved Games 4 Name °
© U.S./Imperial S.L £ Searches
| Client 1_Name A_Rev1_201801241123.vks
18 Computer
[] Name A_Rev.vks
& Floppy Disk Drive (&) =
&, Local Disk (C)
Project Notes < .
< DVD Drive (D) )
Select a file to previes
&3 shared on 'Mac' (V:) file to pr
[C5"engineering on 'Mac' (W)
FBCLockFolder
Temporaryltems
2018 Projects
ASTMS - - >
File name: *vks + | KeyWallPRO Files -
Project Files —
W:\2018 Projects /3\
Version: 1.38.13.801 [AASHTO 2010 (LRFD) — U Keystone Retaining Wall Systems LLC

Load Project ==
Loading From: Delete Project_Revl.vks
Client:  Delete Project
Project: Delete Project [Rev. 1]

This project is already on file.
- You may add it as Revision 2
- or as a new Project.

[ | Load as New Project | [ "] Load as New Revision |

[ % concel |

@
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Exit Program
(or Open/New Project)

KeyWallPRO will ask the User to confirm the automatic backup file process when:

1. Selecting Exit from the File Menu when a current project is open.
2. Selecting New Project or Open Project when a current project is open.

Selecting Yes will save and replace the previous backup copy for the current project. Selecting No will
not replace the backup copy if desired by the User.

This provision is to ensure that a backup file copy would not be accidentally overwritten by another User
using or reviewing a backup file on a network or shared directory with the same backup file path. It also
notifies the User that this backup process is occuring when quitting or changing projects.

{KJ Project Number A: Name A [Rev. 1] - KeyWallPRO =8 =R ===
Walls ~ Settings  Help
Dl ' KeyWall PRE
2 )| srenrene.. eyWa

Save As .. Ctrl+S Revisions

Load Project From ... Ctrl+L

Number Created Last Modified
New Project From Template » 21 T T
Save Project as Template CtrleT
PDF Report ... Ctrl+P
Export to AutoCad ...

Export to GSlope ... [ Foomy | [ P setasacte [ = Delete |

Export to ReSSA ...
5 Confim ==

‘o‘ Al project data has been saved

Save current project revision to the backup directory
location?

Measure
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Create Wall
Project Notes

Import Block Definition File

ﬂ[ Exit -

Project Files

Folder Path
W:\2018 Projects
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